Re: Check Mandatory not working in read only and previously hidden fields

Home Forum General Check Mandatory not working in read only and previously hidden fields Re: Check Mandatory not working in read only and previously hidden fields

#5151

tmrhymer
Participant

Well the read only fields are filled by results from connect commands, they need to have specific values for integration with other systems later on, and are not things we want to leave up to the user to mess up. The dropdown that controls what is displayed in this particular read only field is filled with a connect command, and since connect commands don’t prepend an empty selection when results are added to a dropdown, I can’t use that for my check mandatory because it has a value set by default. Although I see when you use a predefined list with a dropdown it gets the blank first selection. It would be nice if that were the case when adding items to a dropdown through a connect command. Or it would be nice if you could set what value should be considered as unanswered. Like if you had “select” as your first option in the dropdown check mandatory would see that as not having a value.

You asked what fields were involved. They are all text inputs, dropdowns, and radiobutton lists. Some of the radio button lists I’ve just given them a default, but for others a default isn’t really appropriate and the user needs to make their own selection. One thing thats strange is that I have 2 radio button lists. Neither one is special in any way but both are required and do not have a default option selected. Both are in the same check mandatory command but only one of them shows the red border. So that doesnt make sense to me.

You say, “not all of them WILL show with a red border initially”, what are the exceptions for this?