API and WSDL not responding

Home Forum API API and WSDL not responding

This topic contains 11 replies, has 4 voices, and was last updated by  Dennis @ PerfectForms 5 years, 5 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #503

    jasoncmcg
    Participant

    The main url is setup as an https. (There is no http link for our onsite PF.)

    Export scheduler says “Unable to connect to PF API using the supplied credentials”.

    Putting ?wsdl on the end of a form api link gives “500 – Internal server error.

    There is a problem with the resource you are looking for, and it cannot be displayed.”

    Attempting to display the asmx api link in a browser gives the same response as the WSDL.

    Crossdomain.xml in “C:Program FilesPerfectForms” has

    “<?xml version=”1.0”?>

    <!DOCTYPE cross-domain-policy SYSTEM “http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd”>

    <cross-domain-policy>

    <allow-access-from domain=”*” secure=”false”/>

    <allow-http-request-headers-from domain=”*” headers=”*” secure=”false”/>

    </cross-domain-policy>”

    #5286

    CJ Hines
    Participant

    1.Have you enabled the API connection on your dashboard yet?

    Settings tab > Settings > enable API checkbox

    2.Then you must enable API for each user you would like (must be full user)

    Settings tab > Users > (choose user) > check the API checkbox > click Send API key

    Retrieve key and use as key to set up connection.

    #5287

    jasoncmcg
    Participant

    Yes, it is enabled with all machines on our network allowed to use it.

    I am a full user and have my API key.

    #5288

    CJ Hines
    Participant

    Try getting a new API key and use it.

    #5289

    jasoncmcg
    Participant

    A new api key results in the same.

    Please note the following:

    This returns the proper screen: http://app.perfectforms.com/api/api.asmx

    The equivalent path on our server with http returns 403 forbidden access.

    The equivalent path on our server with https returns 500 Internal server error

    #5290

    CJ Hines
    Participant

    I would try deleting and retrying the whole connection.. Directions are located here:

    http://www.perfectforms.com/Documentation/manual/html/d_connectionsintegration.htm

    Let me know what happens afterward.

    #5294

    jasoncmcg
    Participant

    It took me awhile to see what you were talking about. Since I cannot get the API to work, I will look at using the ‘connections’ feature to piece together something that will work.

    Thanks

    #5346

    tmrhymer
    Participant

    I also get the error: 500 – Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed.
    I’m just going through the help documentation trying to build the sample project. When i get to the part about adding a service reference, that is not working and when i try to navigate to myserver/api/api.asmx?wsdl i am getting the 500 error.

    #6511

    jasoncmcg
    Participant

    OK, some time has gone by and there have been some updates. I thought I would try this again.
    PF V. 1.18
    DataExportScheduler 1.18

    Settings Tab > Account Settings > Settings > Application Programming Interface (API)
    Enabled: Checked
    IP Addresses: *

    Settings Tab > Account Settings > Settings > Users > [My Username]
    Full User: Yes
    All Options Selected (including API): Yes
    Send API Key Button: Yes (I have the key)

    Then, I went to a form and obtained the API path:
    [fully qualified server name]/[path we use for all forms and login]/api/forms[form info].asmx

    Transform this into the plain path:
    [fully qualified server name]/[path we use for all forms and login]/api/api.asmx

    Now, I open up the PerfectForms Export Scheduler:
    Configuration Tab > Output Folder
    [Browsed to the desktop and see folder path in the textbox]

    Configuration Tab > API Configuration
    Username: [tried both full email that I use to login and just the username]
    Password: [entered password used to login to PF]
    API Key: [used key obtained from earlier.. copied and pasted]
    API Address: [copied the form api path], [also tried the api/api.asmx path]

    With all of this setup, I click the ‘Test Connection’ button and receive the following error:
    “Unable to connect to the PerfectForms API using the supplied credentials.Please verify the input.”

    What am I missing??

    #6514

    Please check a couple of things:

    1) Paste the API Reference link in a browser to see if you can open it.

    2) Refresh your API Key and try it.

    #6515

    jasoncmcg
    Participant

    500 – Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    Would this have anything to do with the https?
    Is there another server setting that needs to be configured?

    #6517

    Try it with HTTP rather than HTTPS. ┬áThere clearly is something blocking it, but I don’t know what. Disable the firewall and test it from a browser on the application server.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.