Email notification link – Server error 404

Home Forum General Email notification link – Server error 404

This topic contains 5 replies, has 0 voices, and was last updated by  Peanuts890 9 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #305

    Peanuts890
    Participant

    I am currently running my first form in draft mode. When I send an email notification with a link, clicking on the link produces a Server Error “404- File or directory not found”

    I have checked that the recipient of the email is listed as a user and that “everyone” permissions are active. Is there any other conditions that should be met and indeed should this work okay in draft mode. Assuming these are okay, will have the challenge of getting the IT staff involved.

    Thanks

    #4770

    ijobling
    Participant

    have a look at the URL’s you use to log into the application and then compare it to the link you are clicking in the email you have received.
    they should be similar (ie <yourwebserver>/perfectforms). if not, your IT people should be able to see why they are different and probably a ‘rule’ in a firewall/proxy server needs updating.

    #4777

    teejayuu
    Participant

    Hi

    The URL to the form is forms.company.org/player.htm?f=KhAggAMh while the URL in the notification is forms.company.org/player.htm?f=EkgAgGgAgAAgCAAC.

    At present this is on our LAN and therefore is not monitored by the corporate firewall. As a test I also turned off both the web server firewall and the client firewall and still got the same error.

    Cheers
    Tony

    #4779

    ijobling
    Participant

    I assume that since this form was run and the notification email sent out the form hasn’t changed at all (ie if the ‘draft’ data has been deleted it will no longer be accessible) but where the link is to the same URL (the difference in the parameters is simply where the first link is to the form, and the second is to the same form, but to the specific INSTANCE of the form) then the form should present.

    #4780

    teejayuu
    Participant

    All sorted – the link in the e-mail was mis-formed. When I read it back it actually was: forms.company.org//main.html/player.htm?f=EkgAgGgAgAAgCAAC.

    This was in Account > Settings > Single Sign-On > Gateway URL. Changed this and everything now seems to work.

    #4781

    ijobling
    Participant

    Well found and sorted

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.