Having trouble establishing my connection agent behind a firewall

Home Forum Integrating PerfectForms Having trouble establishing my connection agent behind a firewall

This topic contains 0 replies, has 0 voices, and was last updated by  ehuezo 9 years, 11 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #125

    ehuezo
    Keymaster

    Here’s an example:

    Your Agent URL is agent.URL.com, and is installed on port 8080. Port 80 is mapped on your firewall to an inside server “A” on port 8080. You have Tomcat 6 with Java 6 (Update 3) running on that server on port 8080. Any request that comes in on port 80 on agent.URL.com is translated by the firewall to server A:8080.

    Symptoms: The software is installed as outlined in our installation doc. When the Agent URL is accessed, you see the “agent running” message as expected. However, when going to the PF dashboard to test the connection, you received a ‘conenction failed’ message. There were no log files created for the test. All of the files were extracted and in the right directories and the information in the config.xml has been verified to be correct.

    Resolution: The problem was with Apache’s security configuration (even the default one). Apache has a security setting (especially when servers are behind firewalls — which should always be the case) that prevents cross-domain transfers. The issue is documented here for various back-ends:

    http://www.element-it.com/OnlineHelpMulti/Troubleshooting.html

    For future reference:

    On Apache you need a .htaccess file with the following settings:

    SecFilterEngine Off

    SecFilterScanPOST Off

    in the root folder.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.