jasoncmcg

Forum Replies Created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • in reply to: API and WSDL not responding #6515

    jasoncmcg
    Participant

    500 – Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.

    Would this have anything to do with the https?
    Is there another server setting that needs to be configured?

    in reply to: API and WSDL not responding #6511

    jasoncmcg
    Participant

    OK, some time has gone by and there have been some updates. I thought I would try this again.
    PF V. 1.18
    DataExportScheduler 1.18

    Settings Tab > Account Settings > Settings > Application Programming Interface (API)
    Enabled: Checked
    IP Addresses: *

    Settings Tab > Account Settings > Settings > Users > [My Username]
    Full User: Yes
    All Options Selected (including API): Yes
    Send API Key Button: Yes (I have the key)

    Then, I went to a form and obtained the API path:
    [fully qualified server name]/[path we use for all forms and login]/api/forms[form info].asmx

    Transform this into the plain path:
    [fully qualified server name]/[path we use for all forms and login]/api/api.asmx

    Now, I open up the PerfectForms Export Scheduler:
    Configuration Tab > Output Folder
    [Browsed to the desktop and see folder path in the textbox]

    Configuration Tab > API Configuration
    Username: [tried both full email that I use to login and just the username]
    Password: [entered password used to login to PF]
    API Key: [used key obtained from earlier.. copied and pasted]
    API Address: [copied the form api path], [also tried the api/api.asmx path]

    With all of this setup, I click the ‘Test Connection’ button and receive the following error:
    “Unable to connect to the PerfectForms API using the supplied credentials.Please verify the input.”

    What am I missing??

    in reply to: API and WSDL not responding #5294

    jasoncmcg
    Participant

    It took me awhile to see what you were talking about. Since I cannot get the API to work, I will look at using the ‘connections’ feature to piece together something that will work.

    Thanks

    in reply to: API and WSDL not responding #5289

    jasoncmcg
    Participant

    A new api key results in the same.

    Please note the following:

    This returns the proper screen: //app.perfectforms.com/api/api.asmx

    The equivalent path on our server with http returns 403 forbidden access.

    The equivalent path on our server with https returns 500 Internal server error

    in reply to: API and WSDL not responding #5287

    jasoncmcg
    Participant

    Yes, it is enabled with all machines on our network allowed to use it.

    I am a full user and have my API key.

    in reply to: Update Data List Name via Behaviors #5202

    jasoncmcg
    Participant

    Exposing all properties to all controls would significantly increase the power and flexibility of this application. If simplicity for the user is a concern, which could easily resolved by placing these other items under an advanced subsection.

    I seem to run across this situation quite frequently. So, I am sure others see it at least occasionally.

    in reply to: Display Text with Scrolling and HTML Formatting #5112

    jasoncmcg
    Participant

    That was an excellent suggestion, thanks! I will keep it in mind for the future. What we did in this situation was make a link button to a pdf hosted on the web server.

Viewing 7 posts - 1 through 7 (of 7 total)