What’s New in PerfectForms™ Version 1.17
Release Date: April 26, 2010
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1 Dashboard
1.1

Redesign of Dashboard

The Dashboard has been redesigned to support more streamlined,
centralized and efficient navigation. The key changes include:
1)

2)

3)

4)

5)

The Home page has been retired and primary navigation is now
achieved through tabs introduced in the Dashboard. The new
tabs include Forms, Reports, Notifications, Connections and
Settings.
Key commands and navigation options are now incorporated
into a single toolbar ensuring the available options are more
easily accessible. Shortcut options such as creating a new form
or folder and importing forms, reports, and connections have
been moved to the new toolbar.
Shortcut options that were located on the Overview pages have
also been moved to the toolbar. The options include navigating
back and forth between recently viewed pages, initiating an
undo or redo of a recent change and refreshing the page.
A new Upgrade option is now displayed for trial and standard
license On Demand users. The Upgrade link displays a payment
form depending on the user type.
Overview pages for forms, reports, notifications, etc. have been
renamed Dashboards.

Additional detail regarding the location of Home page functionality in
previous versions of PerfectForms vs. where that functionality is now
located is included in the next few sections of these release notes.
Video: Full User Dashboard
Video: Basic User Dashboard
PerfectForms™ Dashboards
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1.2

Creating, Editing and Viewing Forms

Previously the options to create, edit and view forms were located on the Home page under three different links: Edit > Forms, Edit > Create a New Form, and View >
Forms. These options have been combined under a single Dashboard tab titled “Forms”. The Forms Dashboard enables you to view form instances you are involved with
and design or edit forms for which you have edit permissions.
Forms Dashboard

PerfectForms™ Version 1.17 Release Notes

Page 4 of 23

1.3

Creating, Editing and Viewing Reports

Previously the options to create, edit and view reports were located on the Home page under three different links: Edit > Reports, Edit > Create a New Report, and View >
Reports. These options have been combined under a single Dashboard tab titled “Reports”. The Reports Dashboard allows viewing of reports and design or editing of
reports for which you have edit permissions.
Reports Dashboard
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1.4

Viewing Notifications

Previously the ability to view notifications that involve you was located on the Home page under the View > Notifications link. This option has been moved to the
Dashboard tab titled “Notifications”. Any notifications requiring your attention are shown on this page. You may also search for notifications by title using the Search area.
Notifications Dashboard
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1.5

Administering Connections

Previously the ability to create or edit connections was located on the Home page under the Administer > Connections link. This option has been moved to the Dashboard
tab titled “Connections”. The Connections Dashboard allows you to integrate your forms with other systems. Integrating allows you to build powerful applications that
read data from and write data to databases, Web services, text files, other forms and directory services such as Active Directory.
Connections Dashboard
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1.6

Administering Settings

Previously the ability to administer personal as well as account-level settings was located on the Home page under the Administer > My Details link. This option has been
moved to the Dashboard tab titled “Settings”. The Settings Dashboard allows you to create system resources (such as lists or e-mail servers), edit personal details for your
account, change account settings and, if you have appropriate permissions, create and edit users, user-groups and positions.
Settings Dashboard
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2 Form Designer
2.1

Embedded Tutorial Video after First Login in Version 1.17

A video providing an overview of the capabilities of the form designer and the report designer will automatically launch when users first open either designer in version
1.17. This will only occur the first time the user opens the designer.

2.2

Form Time-Out Maximum Value Extended

The maximum allowable value in the Form Properties > Advanced > Time-Out property is 6 days (9999 minutes).
Form Properties

3 Report Designer
3.1

Date Functions Added

Two date functions are now available in the Report Designer’s Formula and Condition Editor: Date Difference and Date Add. If Date in reporting formula is left empty, it is
the same as "Current". These functions can be used to calculate the days a form instance has been open. Units are:
year - yy
quarter - q
month - m
day - d
week - wk
hour - hh
minute - n
second - s
millisecond – ms
Functions Reference Table
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4 Integration
4.1

Ability to Synchronize Users, UserGroups and Positions with a
Network Directory Service

Some customers maintain a Directory Service
which contains all their employees/users.
Previously, when they adopted PerfectForms, they
had to re-create the directory in PerfectForms.
Consequently, whenever a change occurred (e.g.
user added/modified/deleted, user’s membership
of group changes), they had to manually mirror this
change on the PerfectForms system.
Now, using the Synchronize screen on the Settings
Dashboard, they can create a connection between
that directory service and PerfectForms which
allows PerfectForms to access the user information
in that directory service and apply it to the
PerfectForms environment.
Note: Changes in PerfectForms cannot trigger
changes in the customer’s Directory Service
system. The integration is one-way only.
Synchronizing with a Network Directory Service
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5 On Premise
5.1

Installer Upgrades to Preserve
Re-branding Settings

For partner organizations that have re-branded
the application, a new setting in the
installation wizard is now available ‘Enable
Rebranding’. Check this option to preserve
your installation’s previous re-branding and
customization settings.
Running the Installation
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6 On Premise Administration Console
6.1

New User Role: Limited User

In addition to Full User and Basic User, a new
user Role that will only access PerfectForms
from links in system-generated e-mails or from
other public links is now available. While the
user will not be able to log in to the
application, they can be assigned to usergroups and positions and can receive
notifications. Note that this user Role does not
count against the total user count (either basic
or full) allowed for this account.
Creating a New User
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6.2

Flexible Use of Full User Licenses

Full licenses can be assigned as either Full User
or Basic User roles by the administrator on the
Settings Dashboard in the User’s view.
For Basic User licenses, only a Basic User role
may be assigned on the Settings Dashboard in
the User’s view.
This gives you flexibility in how you use Full
User licenses.
The Limited User option under Role does not
use a license. These users can only access a
form through a URL or embedded form.
Limited Users do have the ability to be added
to user-groups and positions as well as to
receive notifications.
Creating a New User
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6.3

Ability to Test the E-mail Server
Setup

On the Settings view in the Administration
Console, a new Test Email Server button has
been added to test the E-mail Server
configuration.
Updating the System E-mail Server
Configuration
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6.4

Custom Error Messages

The ability to customize system error messages
is now available for On Premise administrators.
Choose Error Dialog from the Type menu on
the Messages view in the Administration
Console. Select the desired error message in
the Item list then enter custom text in the
Custom field. To insert system tokens, you can
select from the list below the Custom box and
click Insert.
Customizing System Messages and Error
Messages
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7 System
7.1

Ability to Migrate Form Data as
Zip File and Include Attachments

When migrating form data, two new options
are shown on the Migrate dialog: As zip-file
and Include attachments.
Migrating a Form and Exporting Form Data
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7.2

Improved Security for Forgotten
Password

Previously, when a user forgot their password
a system-generated replacement password
was sent by e-mail. E-mail is not considered
optimally secure so now when a user requests
a password, a temporary link is sent allowing
the user to reset their password from within
the application. The account setting that could
be selected to force users to select their own
password has been removed in version 1.17
because the system no longer automatically
generates passwords.
The administrator will use the Send PasswordLink button on the User detail page to e-mail
the link that will allow the user to reset their
password.
Changing or Resetting Your Password
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7.3

New API Method

The new API method GetAsset allows API
developers to include attachment files in their
exports of a form which uses API and has an
attachment object or other means to attach a
file.
Get Asset API Method
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8 List of Defects Resolved
The following reported bugs were resolved in PerfectForms™ version 1.17.
997

Reports: Formula composer does not allow selection of Fields as arguments inside Functions

998

Table/Time input column: The style changes are not reflected in player.

1048

Printing/Headings: When object is resized, text is not properly displayed(multiple rows)

1194

Reporting: Refresh issue on data source, when you press Refresh button a few times, the fields are duplicating

1243

Form Connection: Update Action: update on table columns doesn’t work correctly if table on sender form has only one row

1252

Notification on a date from a field works only with date input and calendar

1266

Alternative upload screen: Very small form buttons with IE8

1405

Forms/Reports design: Help Center is shown in “View” menu only after page reload

1425

Copy-Paste a Notify Command generates same ID for the copied one

1431

Data List/Grid : Flash player error appears when you open Meta Link in the same window

1441

Admin Console - Documents: Import button available for sample forms, although it only works for library

1455

Account->Resources->Lists: Data from Quick Paste area disappears on minimize

1460

Forms Library: Preview on forms with no screenshot is taken from other forms

1472

No refresh on import, if the node is empty

1474

Account->License: Forms from deleted users are counted for account limitation
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1478

After a form with multiple pages is opened, the &#39;more than one page&#39; message is displayed on forms with a single page as well

1479

Translation error when undo/redo changed page order

1480

Notify - Optional Overrides should be grayed out(visually) when Default Email server is selected

1482

Captcha Properties - translation error length

1483

Radio Buttons and Check Boxes on mouse-over

1489

Drop Down object: More than one item seems to be selected as default(only visual)

1500

Form Connection Update action does not update fields of some types that were left empty (on the source form instance)

1505

Instances are not refreshed in the tree if node is empty

1506

Delete closed instance -> node is not refreshed

1514

Grammatical error on Dashboard>>Accounts and Notify dialog in form designer in 1.16

1520

Flash player error appears when using submit, close commands on Table “loses focus”

1525

Vertical Slider: Accessibility section is missing

1526

Error appears if export is canceled

1528

Jaws compatibility: Forms issues

1529

Undo update account does not work for contact details

1538

Mask : Object is not correctly resized when length is changed

1543

States Overview Panel: After reset, states are not correctly displayed

1545

Exit button: No confirmation message on screens with unsaved changes
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1548

Pictures are not correctly displayed in Printing when state is Normal

1550

Pictures manipulated with Set Property are not correctly reflected in Printing

1551

Opening an instance from datalist in the same page shows flex error

1552

File attachment: When you save an attached file, if the name contains a “space” character, extension is lost (Firefox)

1553

Position: Editing description field: Apply Changes button does not appear until the field loses focus

1554

Redo new form/report: System error appears

1555

List: Error message on redo, after undo new.

1557

Table - Button Column: Corner Radius drop down is empty, default should be 0

1558

Redo update connection: error message if redo action is after undo new

1559

Redo update action: flash player error if redo action is after undo new

1560

Redo update users / groups / positions: nothing happens if redo action is after undo new

1561

Table - Some columns are affected by background color in design

1567

Table: No selection after a table column is deleted

1570

Account Resources ->Lists: Characters like ", <, > are not supported on Caption

1586

Date Difference functions do not work when spanning over a Month

1598

Reports: Datalists page button go to last page is backward

1604

Not possible to create draft instances of a form that is version 0.1

1605

Reports: Gauge object colors have reverted to the default settings
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1606

Reports/Data source: When you edit an existing filter if you press Ok or Cancel filter is lost

1613

Formula Composer: Functions: when adding a new form field as a function parameter, the parameter field displays &#39;undefined&#39; until the formula is
saved

1615

Data exported via a report: "&" and " ' " are exported like " amp " and " O&#39 "

1619

Reports on which previous versions were deleted couldn’t be published anymore

1632

Translation error when My Details - New Password field is left empty

1633

Form Connection: Insert in table columns is not working correctly (empty row is added, no data inside)

1639

Printing: Tables: When column header is multi-line and printed the pdf shows header in single line and truncated.

1641

Add method of API is not working (on the quotation form)

1648

Kiosk mode is not working

1653

Email server service locks up in the event of a SQL server restart or loss of connection.

1654

Printing: no data on printed report if the report has a draft version

1666

Bullet Text boxes and printing

1667

Bullet Text: Bullet appears on empty line only in printing

1670

Unable to view all form instances in Tree - see attached

1675

Notifications not always removed when &#39;Delete Previous Versions&#39; is used

1734

Notifications sent to a date taken from a text field: if the text field is empty or contains random text, the activation date becomes 0000-00-00

1761

Table: System error appears when printing a table with a specific size
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1793

User Details: The user should not be able to deactivate himself

1808

Login / Forgot Password / Sign Up etc.. screens should not have ":" at end of labels

1827

Numeric Input Object: When empty NI object should be considered zero?
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